RSSThe TSW Blog

Improving the usability of TSW WebCoder 2013 part 3: Firefox preview and XulRunner installation

September 18, 2012

WebCoder has supported previewing your content internally in Firefox for several versions now. It relies on the so-called XulRunner components, which are a part of the Firefox browser. At one point, it was enough to simply have Firefox installed to use this feature, but because Firefox are being updated so rapidly these days, WebCoder can't rely on the user having a compatible version of Firefox installed. Therefore, previous WebCoder versions had a link to a compatible XulRunner package, exclusively for previewing in WebCoder - a simple zip file, that you could unpack and then enter the proper path into WebCoder.

However, this might have been a bit too technical and too big a bother for some users, judging by the support mails I got. I therefore decided to streamline the process quite a bit for WebCoder 2012, by presenting the user with a dedicated and informative dialog instead of the old Windows message box. Here's how it looks when you try to activate the Firefox preview without having the necessary XulRunner components:

xulrunner_dialog

 

Unless you have already downloaded the correct XulRunner package, you simply click the Download now button and WebCoder will download it for you directly through the dialog:

 

xulrunner_downloading

 

As soon as the download finishes, WebCoder will automatically unzip the package, place it within your WebCoder installation and fill out the path for you:

 

xulrunner_downloaded

 

The only thing left to do for you is to click the Ok button and you're ready to start previewing in Firefox :)

This is yet another one of those small, nice-to-have improvements that I hope you will like!

Kasper (TSW) @ 1:58 pm in TSW,WebCoder

2 Responses to “Improving the usability of TSW WebCoder 2013 part 3: Firefox preview and XulRunner installation”

  1. MooreHojer says:

    Will it also be able to update when a newer compatible version is out? Or is that not an issue?

  2. Kasper (TSW) says:

    WebCoder is built (compiled) with support for a specific version of Firefox/XulRunner, so to use a newer version, I will have to re-compile WebCoder and then make a new release. I will of course do that if the customers are requesting it :)

Leave a Reply